Rosetta Ignores Disk Usage Settings

Graham Jenkins ID: 1626 Posts: 123
28 Dec 2021 09:26 AM

Rosetta seems to be ignoring the 20GB limit I've set, as shown in the attachments. In consequence, the relevant filesystem eventually becomes 100% full and everything stops. Is there a way I can stop this from happening? Or should I just disable Rosetta and allow LHC tasks instead?

Tristan Olive ID: 22 Posts: 339
29 Dec 2021 10:25 PM

Is it possible that the Rosetta data was downloaded before you changed the disk usage settings, and now those files are just stuck there wasting storage space? Under normal circumstances, you'd get a notice in BOINC if a task requires more disk space than is available, e.g. "Rosetta needs 25GB of disk space, but only 20GB is available." You could try manually removing Rosetta data under ProgramData/BOINC/projects/ to see if that helps, but if it is ignoring preferences, I suppose it would just download it all again.

Which version of BOINC are you running? And do you have a separate disk partition for BOINC data, or is it on the primary / C drive?

Graham Jenkins ID: 1626 Posts: 123
29 Dec 2021 11:52 PM

No, all Rosetta data was cleared (along with everything else) when the (Linux root) disk filled up, and I had to do a "Sychronise with Charity Engine" to get new jobs.

Since then I've had to do a "Reset Project" to clear all Rosetta data when the disk is about to fill.

I'm using version 7.16.6 (x64) on Ubuntu 20.04.03 LTS (package 7.16.6+dfsg-1). It doesn't offer any option about where data should be stored.

Graham Jenkins ID: 1626 Posts: 123
29 Dec 2021 11:54 PM

Oh .. and I occasionally get a notice like: "Rosetta needs 25GB of disk space, but only 20GB is available." But sometimes I don't, and that's when the issue arises.