WorldCommunityGrid missing account key

AR
Adam Radocz ID: 22746 Posts: 72
29 Jan 2021 04:47 PM

Hi,

The WCG is attached to my PC, but it says "Invalid or missing account key.  To fix, remove and add this project ."

I synced the CharityEngine, but it didn't solve the problem.


Tristan Olive ID: 22 Posts: 316
29 Jan 2021 09:36 PM

A bug has been fixed in the routine for registering with WCG and your account has been set to retry on the next sync.

AR
Adam Radocz ID: 22746 Posts: 72
30 Jan 2021 10:38 AM

It downloaded some tasks but the account is still empty. Is that okay?

 
Tristan Olive ID: 22 Posts: 316
30 Jan 2021 04:32 PM

This should not get in the way of credit being awarded. There was an issue in setting the user name for the account, possibly related to the issue that was causing the "Invalid account key" error. It's more of a cosmetic issue than functional, but definitely something to fix on our end.

More to come on this later! Thanks again for working through it with us.

Tristan Olive ID: 22 Posts: 316
01 Feb 2021 10:18 PM

Credits are being granted by WCG, so that confirms functionality is not an issue (you can verify in the client and should see a corresponding uptick in credit here overnight).

We're working with WCG to determine why the user name is missing.

AR
Adam Radocz ID: 22746 Posts: 72
02 Feb 2021 06:07 PM

Great, thanks for the info.

Graham Jenkins ID: 1626 Posts: 106
11 Feb 2021 09:22 PM

I'm not convinced that WCG credits are being applied. I can see in my Statistics view that WCG work is being done, but the "More Stats" view on the web page shows that no work has been done for several days.

Can you please check?

 

Tristan Olive ID: 22 Posts: 316
12 Feb 2021 06:40 PM

You're onto something, Graham. The credits are being counted at WCG, but it looks like they're being excluded from the stats export, which means we don't see them here. I think I know why this is happening, so I'll try for a fix today and then we should see stats showing up in a day or two.

AR
Adam Radocz ID: 22746 Posts: 72
14 Feb 2021 10:11 AM

The lost points going to count in the upcomming draw?

 
Tristan Olive ID: 22 Posts: 316
15 Feb 2021 11:59 PM

Fixing the issue requires some help on the WCG side of things, as there's a hangup in the API for granting user consent for exporting stats. It's looking like it won't be in time for this drawing, but we'll see if it can fall into place quickly enough.

Graham Jenkins ID: 1626 Posts: 106
16 Feb 2021 01:56 AM

Thanks Tristan. I look forward to testing it!

Graham Jenkins ID: 1626 Posts: 106
23 Feb 2021 09:40 AM

Any progress with this yet?

Tristan Olive ID: 22 Posts: 316
10 Mar 2021 10:44 PM

Nothing to report so far, I'm sorry to say. I've checked in with WCG to see if there's anything we can do to help.

Graham Jenkins ID: 1626 Posts: 106
18 May 2021 09:15 PM

I seems like the WCG credits still not being applied to our account statistics, and this somewhat diminishes the participation incentives for those of us with limited machine resources.

Can you please revisit this issue?

Tristan Olive ID: 22 Posts: 316
19 May 2021 03:06 AM

Checking in again -- thanks for bringing this back up, Graham.

Graham Jenkins ID: 1626 Posts: 106
25 May 2021 09:26 PM

Tristan, how did you get on? I recently acquired a more powerful machine, and it's doing a lot of WCG tasks .. with no apparent credits being applied :(

Graham Jenkins ID: 1626 Posts: 106
11 Jun 2021 08:21 AM

Tristan, have you been able to get this working. My machines are doing lots of WCG work, and I'm getting no points for any of it :(